Z Axis troubleshooting

From RigidWiki
Jump to: navigation, search

The Z-axis of the Rigidbot is tightly constrained; some believe it to be over-constrained. This can lead to binding, which usually occurs toward the motors (at the bottom for stock configuration, at the top for inverted Z modification). "Upgraded Z" machines are likely more susceptible, due to the rigid incorporation of the lead screw, vs. the semi-flexibility of those with a connector between the motor and lead screw.

Others have suggested leaving various screws loose to allow movement, but the following procedure uses the parts as intended.

Dennis Brown's "Fix the Alignment" Method

This procedure is translated (with minor editing) from Dennis Brown's G+ Rigidbot Community post, with his permission. (https://plus.google.com/102831253296337169949/posts/fko2cXiVQdD)

  1. Start with the Z all the way up.
    • You may have to help it get unstuck at the bottom.
    • Make sure you have a light oil (like 3in1 oil) on the lead screw.
    • If you lightly crash the gantry into the top frame, it should equalize the lead screw heights. You can turn the lead screws by hand to do this.
  2. Remove 2 lead nut screws and loosen the 3rd one from the plastic piece #1007 on both sides.
  3. Loosen the screws to the vertical smooth rods on the middle frame, top frame, and the one accessible linear bearing holder on the gantry on each side.
  4. Home Z down to the bottom. Then tighten the middle frame smooth rod holders and the one gantry linear bearing holder again on both sides.
  5. Run the Z up to the top and tighten the top frame smooth rod screws. This should take care of any lateral alignment errors on the vertical smooth rods, assuming that there is enough play in the screw holes.
  6. Home the Z again.
  7. Remove the 3rd lead nut screw from the plastic piece #1007 on both sides. That plastic piece touches the metal bar #1020 the way I initially built mine.
  8. Raise one side or the other of the gantry about 1/4 inch to see if there is freedom or friction in movement where the screw goes through the plastic hole in #1007. Also flex the lead screw from the top in each of 4 X,Y directions to see how close it was to having friction.
    • If there is a lot of friction and binding on the side of the hole towards the center of the bot, used a flat blade screwdriver to pry #1007 away from #1020 a little bit, until there was no friction on the lead screw. It has a very tight fit on the smooth bars and does not want to move easily.
    • If there is a lot of friction and binding on the side of the hole towards the front or back of the bot, loosen the X gantry smooth bar mounts on #1020 and slide #1007 over slightly and re-tighten them.
    • Now there should be no friction anywhere.
  9. Replace the 6 lead nut screws and tighten them.
  10. Run the Z up to the top and lightly crash it into the top frame again to equalize the nuts and create a reference for leveling the bed.
  11. Loosen and re-tighten the screws to the vertical smooth rods on the top frame.

Now everything is in good alignment and no screws are loose. It is important to have tight screws to keep everything stable.


Other things to do/check/try.

  1. Your z-axis lead screws should be free of machining debris. If you didn't do this on assembly, use a brass bristle brush and suitable solvent to clean the threads. Then lubricate them with light machine oil or superlube.
  2. Your z-axis stepper driver may be under or over-driven. Either can lead to missing steps and apparent binding. See http://rigidtalk.com/wiki/index.php?title=Stepper_Driver_Adjustment
  3. You can increase the available torque on the z-axis to try to overcome any residual binding by wiring the z stepper motors in series instead of parallel. See http://rigidtalk.com/wiki/index.php?title=Z-Axis_Stepper_Motor_-_Series_Connected_Splitter_Board