Cannot connect to the printer

Troubleshooting any electronic elements of the RigidBot

Cannot connect to the printer

Postby rejsmont » 30 Oct 2014, 09:05

Hi guys,

Yesterday I made my first print and it went all OK. After the print I have allowed everything to cool down and powered the printer off (leaving both power supply and USB cables connected). Today I have turned the printer on and the power supply has immediately shut down (it was quite warm). I have turned the printer and the power supply off and let them both cool down. After 1 hour I gave it another try. The printer has turned on, the LCD screen was showing the usual stuff, but I could not establish connection with the printer (tried CURA and pronterface). I have checked if system detects the USB device, but plugging and unplugging USB cable did not show anything in dmesg. The temperature sensor readings on LCD were showing 117 and 119 degrees, although both nozzle and bed were cool. I tried using LCD control, but I could not make the printer do anything: have tried homing, but only thing that happened was Z motor buzzing for a minute and stopping.

Do you guys have an idea what could have happened?

Best,

Radek
rejsmont
 
Posts: 7
Joined: 07 Oct 2014, 09:53

Re: Cannot connect to the printer

Postby rejsmont » 31 Oct 2014, 12:23

Hi folks,

just a follow up - I have removed the logic board from the printer and tested if when isolated it would speak to the arduino IDE over USB, but it still does not even establish a serial port nor does it appear on the lsusb / usbview.

Is there a way to use serial port to connect to the ATmega and reflash it? Could the power surge from the power supply cause firmware reset?

Another theory - if the power supply failed partially, is that possible that I am getting voltage only on some components? The connector has 4 pins - is it supplying multiple voltages simultaneously? Which pins are supposed to be hot, which ground?

Thanks in advance for your help!


Best,

Radek
rejsmont
 
Posts: 7
Joined: 07 Oct 2014, 09:53

Re: Cannot connect to the printer

Postby rejsmont » 03 Nov 2014, 10:05

@spiderdaddy - do you maybe have an idea? Should I get the new mainboard? Does IAP provide mainboards?

Best,

Radek
rejsmont
 
Posts: 7
Joined: 07 Oct 2014, 09:53

Re: Cannot connect to the printer

Postby mike andrews » 02 Dec 2014, 23:06

i have same experience, almost identical in fact. No ideas to solve problem. my condolences. If a solution comes I will post it. In the meantime, I will probably order a new board. mike
mike andrews
 
Posts: 2
Joined: 02 Dec 2014, 22:57


Return to Electronics

Who is online

Users browsing this forum: No registered users and 2 guests